События

В конце года 62% всех сайтов в интернете лишатся обновлений безопасности

По данным W3Techs, на сегодняшний день около 78,9% всех сайтов в интернете работают на PHP. Однако 31 декабря нынешнего года официально прекращается выпуск обновлений безопасности для PHP 5.6.x, что ознаменует полное прекращение поддержки всех версий устаревшей ветки PHP 5.x.

В начале 2019 года из-за прекращения поддержки около 62% сайтов, до сих пор работающих на версиях PHP 5.x, перестанут получать обновления безопасности, а значит, сотни миллионов ресурсов окажутся под серьезной угрозой. Если после Нового года киберпреступники обнаружат в PHP уязвимость, огромное число сайтов и их пользователей подвергнутся большому риску.

По словам директора по разработкам компании Paragon Initiative Enterprise Скотта Арцишевски (Scott Arciszewski), возможность эксплуатации уязвимостей в неподдерживаемых версиях представляет «огромную проблему для экосистемы PHP».

«Многие не могут вот так просто взять и отказаться от PHP 5 в 2019 году. Это решение (команды PHP – ред.) является необдуманным», – сообщил Арцишевски в интервью изданию ZDNet.

По мнению эксперта, серьезные, широко эксплуатируемые уязвимости в PHP 5.6 наверняка затронут и более новые версии. «PHP 7.2 будет регулярно получать бесплатные патчи от команды PHP; PHP 5.6 получит патч, только если вы платите за продолжающуюся поддержку производителю вашей ОС», – отметил Арцишевски.

Сообществу PHP уже давно было известно о планируемом прекращении поддержки. Когда весной 2017 года 5.6 стала самой популярной версией PHP, разработчики решили повременить с прекращением поддержки и продлить ее до конца 2018 года.

Тем не менее, поголовного перехода на ветку 7.х не произошло. Только системы управления контентом (CMS) постепенно стали модифицировать минимальные требования и предупреждать пользователей о необходимости перехода на более современную хостинговую среду. Из трех крупнейших CMS (WordPress, Joomla и Drupal) только Drupal указала PHP 7 в минимальных обязательных требованиях, хотя ветка PHP 7.0.х устарела еще 3 декабря 2017 года. В минимальных требованиях Joomla до сих пор указана версия PHP 5.3, а WordPress – PHP 5.2.

Источник

Автор: Сергей Куприянов
15.10.2018 (10:16)
Пройди тест и узнай об этом!
Информер новостей
Расширение для Google Chrome
Пишите нам

Редакция: info@alterprogs.ru

Реклама: adv@alterprogs.ru

Все права защищены © 2010-2018

"Alterprogs.ru" - технологии будущего

Контакты  | Карта сайта

Использование любых материалов, размещенных на сайте, разрешается при условии ссылки на alterprogs.ru. Для интернет-изданий - обязательна прямая открытая для поисковых систем гиперссылка. Ссылка должна быть размещена в независимости от полного либо частичного использования материалов. Материалы в рубрике "Новости партнеров" публикуются на правах рекламы.